Sie sind nicht angemeldet.

16

Dienstag, 14. August 2018, 14:57

Heute kam mein SPROG 3. Der Anschluss war kein Problem - er hängt an einem MacBook Pro. Lok auf's Gleis, Reglerfenster aufmachen und ich kann fahren, Sound geht, alles fein.
Aber wenn ich programmieren möchte, dann ist das neue Fenster zwar da, aber leer, es enthält nur einen grauen Rahmen und weiter keinen Inhalt. Ich kann es auch nicht schließen, ich muss DecoderPro dann abschießen.
Ich vermute das Problem bei DecoderPro und/oder Java. JRMI ist aktuell 4.12, gerade neu gedownloadet.
An was kann denn das liegen?

  • »David Moffat« ist männlich

Beiträge: 126

Wohnort: An der Mittenwaldbahn

Beruf: Locomotive Engineer

Hobbys: US Railroad, Eisenbahnfotografie

Spurweite: H0

  • Nachricht senden

15

Samstag, 11. August 2018, 20:32

Hallo Simon, danke für die erste Hilfestellung! Folgendermaßen sieht es aus:
...., sagt mir JMRI das es ein Massoth Decoder sei und nichts anderes. Es Ist aber ein Digitrax DH165K1A verbaut. Wenn ich nun den richtige Decoder auswähle, auf BASIS gehe und die Seite komplett auslese, heißt es, es wäre die Adresse 15227!? ....


Hatte ich vor zwei Monaten auch als ich JMRI und Sprog auf einem WIN10 Laptop eingerichtet habe. Der Port war richtig aber in den anderen Einstellungen zur Verbindung war irgendwas falsch. Ich hab solange probiert bis es ging.
Viele Grüße vom km 63.8 der Mittenwaldbahn, Lutz

  • »Simon_Ginsburg« ist männlich

Beiträge: 2 775

Wohnort: Schweiz

Beruf: Ingenieur..... das ist der mit dem Schraubenschlüssel zwischen den Zähnen....

Hobbys: Modellbahnen, was denn sonst?

Spurweite: N

  • Nachricht senden

14

Samstag, 11. August 2018, 10:00

Hallo Simon, danke für die erste Hilfestellung! Folgendermaßen sieht es aus:
Ich habe den Sprog nicht mehr benutzt, seit dem ich mein Toshiba Notebook komplett neu eingerichtet habe, vorher hatte ich aber die gleichen Probleme.
Ich habe Java und JMRI 4.12 für Windows runtergeladen und installiert. Vorher hatte ich eine ältere Version, mit dieser kenne ich mich noch nicht aus. Wenn ich den Sprog nun an den richtigen USB anschließe und das Netzteil (12V---2A) einstecke leuchten beide LED konstant. Er wird vom PC erkannt und liegt keine Spannung am Gleis an. Sobald ich JMRI öffne fängt die PWR LED an zu blinken und es liegen 12,5V am Gleis an. Der "Einschaltknopf" bei JMRI ist gelb hinterlegt. Wenn ich diesen auf rot mache liegen trotzdem 12,5V an. Wenn ich ihn auf grün mache geht die USB LED aus.

Hier kannst bereits aufhören! Der SPROG wird entweder nicht richtig erkannt oder hat einen Schaden.
Versuche nochmals von Anfang an, den SPROG mit dem richtigen Port zu zu ordnen. Hast Du immer noch dasselbe seltsame Verhalten?
Kannst Du eine alte Version von JMRI installieren mit der es dann funzt? Du kannst problemlos mehrere (viele) Versionen von JMRI parallel auf dem Rechner installieren. Nur laufen lassen solltest Du immer nur eine Version....
Falls das Problem bestehen bleibt, hast Du schon mit Andrew Kontakt aufgenommen?mailto:sprog@sprog-dcc.co.uk Er wäre dann so mein letzter Rat....
Den Rest Deiner Beschreibung spare ich mir, denn wenn obiges schon nicht funzt, dann ist der Rest eh nur sporadisches Falschverstehen zwischen JMRI und SPROG.....
Simon

Modelling the Big Borg and CalTrain in Normal size ....

  • »EMD SD70ACe« ist männlich

Beiträge: 185

Wohnort: Kraichgau

Hobbys: US Modellbahn, Autos

Spurweite: HO, Z

  • Nachricht senden

13

Samstag, 11. August 2018, 08:29

Hallo Simon, danke für die erste Hilfestellung! Folgendermaßen sieht es aus:
Ich habe den Sprog nicht mehr benutzt, seit dem ich mein Toshiba Notebook komplett neu eingerichtet habe, vorher hatte ich aber die gleichen Probleme.
Ich habe Java und JMRI 4.12 für Windows runtergeladen und installiert. Vorher hatte ich eine ältere Version, mit dieser kenne ich mich noch nicht aus. Wenn ich den Sprog nun an den richtigen USB anschließe und das Netzteil (12V---2A) einstecke leuchten beide LED konstant. Er wird vom PC erkannt und liegt keine Spannung am Gleis an. Sobald ich JMRI öffne fängt die PWR LED an zu blinken und es liegen 12,5V am Gleis an. Der "Einschaltknopf" bei JMRI ist gelb hinterlegt. Wenn ich diesen auf rot mache liegen trotzdem 12,5V an. Wenn ich ihn auf grün mache geht die USB LED aus. Eingestellt ist PAGED.
Wenn ich nun eine Lok draufstelle, von der ich sicher die Adresse kenne und Typ aus Decoder auslesen anwähle, sagt mir JMRI das es ein Massoth Decoder sei und nichts anderes. Es Ist aber ein Digitrax DH165K1A verbaut. Wenn ich nun den richtige Decoder auswähle, auf BASIS gehe und die Seite komplett auslese, heißt es, es wäre die Adresse 15227!? Der Motor ruckelt beim auslesen aber nicht wie ich es gewohnt bin. Es lässt sich auch nichts programmieren. Wenn ich nun den Handregler öffne, die Adresse setze und wie gesagt den Schalter auf grün stelle, geht das USB LED aus. Lok lässt sich nicht Fahren.
__________________________
Gruß: Michael

Southern California in H0

  • »Simon_Ginsburg« ist männlich

Beiträge: 2 775

Wohnort: Schweiz

Beruf: Ingenieur..... das ist der mit dem Schraubenschlüssel zwischen den Zähnen....

Hobbys: Modellbahnen, was denn sonst?

Spurweite: N

  • Nachricht senden

12

Freitag, 10. August 2018, 18:11

Da es hier um den Sprog geht schließe ich mich einfach mal mit meinem seit neuesten auftretenden Problem an. Wenn ich meinen Sprog (2v3) wie immer anschließe, leuchten beide LED konstant.Sobald ich etwas auslesen oder schreiben will geht die USB Led aus und die Pwr Led blinkt. Es ist nicht möglich etwas zu lesen oder schreiben. Hat jemand ne Idee was das sein könnte?

Hi Michael,

es gibt viele Möglichkeiten, an was es liegt....
1) Hast Du einen Kurzschluss am Ausgang?
--> Test: Kannst Du in JMRI die Gleisspannung einschalten? Geht das, hast Du Spannung am Ausgang, am Besten mittels DCC RRAmpMeter messen....
Mit DEM Test hätten wir zudem sicher gestellt, dass das Teil auch wirklich addressiert wird....
2) Wählen einer zuverlässigen Lok mit bekannter DCC Adresse. Auf Gleis legen und Throttle mit der Adresse wählen.
--> Fährt die Lok wenn Du im Throttle eine Fahrt einstellst?
Mit DEM Test wäre sicher gestellt, dass auch Leistung vorhanden ist....
3) Neue Lok auf der "was" geschrieben werden kann aufgleisen und einfach "irgendwas" schreiben, geht das?
4) Lesen als Königsdisziplin. Am Besten versuchen via Direct Bit und Paged....

Lass wissen, welche Umgebung Du hast (PC etc.) und WO Du genau stecken bleibst...
Simon

Modelling the Big Borg and CalTrain in Normal size ....

  • »EMD SD70ACe« ist männlich

Beiträge: 185

Wohnort: Kraichgau

Hobbys: US Modellbahn, Autos

Spurweite: HO, Z

  • Nachricht senden

11

Freitag, 10. August 2018, 07:15

Da es hier um den Sprog geht schließe ich mich einfach mal mit meinem seit neuesten auftretenden Problem an. Wenn ich meinen Sprog (2v3) wie immer anschließe, leuchten beide LED konstant.Sobald ich etwas auslesen oder schreiben will geht die USB Led aus und die Pwr Led blinkt. Es ist nicht möglich etwas zu lesen oder schreiben. Hat jemand ne Idee was das sein könnte?
__________________________
Gruß: Michael

Southern California in H0

Beiträge: 283

Wohnort: Bremerhaven

Hobbys: T-Trak irgendwo in der Wüste

Spurweite: N

  • Nachricht senden

10

Freitag, 27. Juli 2018, 20:55

An den Definitionen für TAMS-Decoder in JMRI fummelt (laut Mailing-Liste) gerade jemand herum, würde mich nicht wundern, wenn in ein-zwei Versionen da auch mehr Decoder-Definitionen verfügbar sind...

...ansonsten hat JMRI unter den NMRA-Standard-Decodern auch die Option "Raw CVs 1-256" und "Raw CVs 1-1024" - mit denen du jede CV programmieren kannst, die der Decoder kennt (wenn er für die CVs über 256 das gleiche Verfahren anwendet wie die NMRA vorgibt)

Dazu musst du natürlich wissen, welche CV was bewirkt (->Decoder-Handbuch).

MfG, Heiko

  • »gotransit« ist männlich
  • »gotransit« ist der Autor dieses Themas

Beiträge: 1 025

Wohnort: Berlin

Beruf: Busfahrer

Hobbys: Eisenbahn,Bus

Spurweite: HO

  • Nachricht senden

9

Mittwoch, 25. Juli 2018, 15:51

Ein Post vorher hat Chalie schon was gesagt. Ich kann es leider nicht für dich testen, habe keine Tams. Sollte aber funktionieren.
Zum Sounddecoder. Hat Tams jetzt auch Sounddecoder oder ist der von einem anderen Hersteller.
Wenn der in der Liste ist solltest du den bis auf neuen Sound voll programmieren konner.

Nochmals Danke für die Antworten.
Der LD-G31 ist aber schon lange am Markt, der LD-G31+ auch schon bestimmt 2 Jahre.

Tams, Sound, Nein, das ist eine Intermountain SD40-2, Danach hatte ich in Decoder pro noch nicht gesucht.

DecoderPro hat eine automatische Decodererkennung und kann Baugleiche Decoder finden. Die CVs sind ja auch bei den Herstellern oft identisch von eienr Serie zur nächsten.
Im Prinzip klar, nur der 31 hat 4 Ausgänge, der 32 nur 2.
ich werde mir wohl also nach dem Urlaub ende September einen Sprog zulegen, wird wohl so einiges verreinfachen.
Maurice

8

Dienstag, 24. Juli 2018, 21:13

Die Frage ist doch erst mal was für Decoder hast du die nicht in JMRI enthalten sind.
Vielleicht hast du die nur übersehen?
-Bitte keine „Warum nimmst du keine anderen Decoder“ Diskussion
Bring diese beiden Zitate mal zusammen, die Ja/nein Frage wurde also so nicht akzeptiert.
Nein, ich habe nichts übersehen.
Die Funktionsdecoder von Tams sind hinterlegt
der LD-G31 nicht, auch LD-G31+ nicht, der LD-G32 ist uralt
Gegenfrage: Willst Du "nur" die Adresse und einige andere Standard-CV's programmieren oder willst Du Spezialitäten des Decoders programmieren?

Ich hatte nur eine Grundsatzfrage gestellt.ich habe auch eine Soundlok, an der mich massiv stört, das sie immer von alleine Krach macht, (Anlage an -Krach; Kurzschluss -wieder an -Krach)das kann man abstellen, aber nur oberhalb von CV255, ist aber eigentlich unwichtig, bleibt das Ding eben in der Vitrine

OK, verstanden.
Ein Post vorher hat Chalie schon was gesagt. Ich kann es leider nicht für dich testen, habe keine Tams. Sollte aber funktionieren.
Zum Sounddecoder. Hat Tams jetzt auch Sounddecoder oder ist der von einem anderen Hersteller.
Wenn der in der Liste ist solltest du den bis auf neuen Sound voll programmieren konner.
Der SPROG lohnt sich also immer.
Gruß
Jürgen
US-Modellbahner seit 1975 in (N). Wechsel zu H0 und DCC 1998
Vorbild die Penn Central und Ihre Vorgänger (PRR,NYC,NH) in H0
Mitglied des US-Bahn-Stammtisches Peine

  • »Charlie Barret« ist männlich

Beiträge: 3 389

Wohnort: 50226 Frechen bei Köln

Spurweite: N + H0

  • Nachricht senden

7

Dienstag, 24. Juli 2018, 19:31

DecoderPro hat eine automatische Decodererkennung und kann Baugleiche Decoder finden. Die CVs sind ja auch bei den Herstellern oft identisch von eienr Serie zur nächsten.

Guys, if I don't bleed to death pretty soon, I'm gonna die of boredom.

  • »gotransit« ist männlich
  • »gotransit« ist der Autor dieses Themas

Beiträge: 1 025

Wohnort: Berlin

Beruf: Busfahrer

Hobbys: Eisenbahn,Bus

Spurweite: HO

  • Nachricht senden

6

Dienstag, 24. Juli 2018, 18:38

Die Frage ist doch erst mal was für Decoder hast du die nicht in JMRI enthalten sind.
Vielleicht hast du die nur übersehen?
-Bitte keine „Warum nimmst du keine anderen Decoder“ Diskussion
Bring diese beiden Zitate mal zusammen, die Ja/nein Frage wurde also so nicht akzeptiert.
Nein, ich habe nichts übersehen.
Die Funktionsdecoder von Tams sind hinterlegt
der LD-G31 nicht, auch LD-G31+ nicht, der LD-G32 ist uralt
Gegenfrage: Willst Du "nur" die Adresse und einige andere Standard-CV's programmieren oder willst Du Spezialitäten des Decoders programmieren?

Ich hatte nur eine Grundsatzfrage gestellt.ich habe auch eine Soundlok, an der mich massiv stört, das sie immer von alleine Krach macht, (Anlage an -Krach; Kurzschluss -wieder an -Krach)das kann man abstellen, aber nur oberhalb von CV255, ist aber eigentlich unwichtig, bleibt das Ding eben in der Vitrine
Maurice

5

Montag, 23. Juli 2018, 23:04

Die Frage ist doch erst mal was für Decoder hast du die nicht in JMRI enthalten sind.
Vielleicht hast du die nur übersehen?
Gruß
Jürgen
US-Modellbahner seit 1975 in (N). Wechsel zu H0 und DCC 1998
Vorbild die Penn Central und Ihre Vorgänger (PRR,NYC,NH) in H0
Mitglied des US-Bahn-Stammtisches Peine

  • »Simon_Ginsburg« ist männlich

Beiträge: 2 775

Wohnort: Schweiz

Beruf: Ingenieur..... das ist der mit dem Schraubenschlüssel zwischen den Zähnen....

Hobbys: Modellbahnen, was denn sonst?

Spurweite: N

  • Nachricht senden

4

Montag, 23. Juli 2018, 19:12


Und nun die Frage
Kann man mit einem Sprog, Decoder auslesen UND programmieren, die nicht in JMRI hinterlegt sind?

Hallo Maurice,

Gegenfrage: Willst Du "nur" die Adresse und einige andere Standard-CV's programmieren oder willst Du Spezialitäten des Decoders programmieren?
Falls hier Ersteres, dann kannst Du einfach die Standard NMRA Decoderkonfiguration laden und Du bist gut bedient. Du kannst diese Konfiguration auch speichern und jederzeit wieder verwenden.
Falls Zweiteres erlaube ich mir eine Zusatz-Gegenfrage:

Hast Du eine Dokumentation oder was Vergleichbares, ausder klar wird, welche CV's wie belegt sind (ausser den Standardmässigen)?
Du müsstest zumindest irgendwie wissen, WAS Du WO hinschieben willst.... Die XML Files beschreiben nämlich nix Anderes....
Falls Ja ist es relativ einfach sich selber ein entsprechendes xml file zu erzeugen.
Falls Nein müsstest mal auf der JMRI Gruppe oder an ähnlichen einschlägigen Orten rumfragen, wer bereits Erfahrung mit den speziellen Decodern hat.
Simon

Modelling the Big Borg and CalTrain in Normal size ....

  • »gotransit« ist männlich
  • »gotransit« ist der Autor dieses Themas

Beiträge: 1 025

Wohnort: Berlin

Beruf: Busfahrer

Hobbys: Eisenbahn,Bus

Spurweite: HO

  • Nachricht senden

3

Montag, 23. Juli 2018, 17:41

Ich danke ganz herzlich.
Maurice

  • »bigboy4015« ist männlich

Beiträge: 8 073

Wohnort: Limburg a. d. Lahn

Beruf: Stadtmarketing & Tourismus

Hobbys: der 911, der 917, US-Bahnen und Betreiber eines nicht so kleinen Forums...

Spurweite: Bei Modellbahn immer H0, sonst 1:18-1:32-1:43

  • Nachricht senden

2

Montag, 23. Juli 2018, 17:18

Radio Eriwan antwortet...

Im Prinzip liest der ziemlich jeden Decoder aus. (Meiner zumindest...)

Kann nur sein das der den Typ nicht anzeigt.

*********************************************
Bigboy4015 - Ulrich Wolf - Cajon Pass / Nebraska / Wyoming - DB / SBB / ÖBB - DVB Straßenbahn Dresden - H0

The situation is hopeless but not serious !

  • »gotransit« ist männlich
  • »gotransit« ist der Autor dieses Themas

Beiträge: 1 025

Wohnort: Berlin

Beruf: Busfahrer

Hobbys: Eisenbahn,Bus

Spurweite: HO

  • Nachricht senden

1

Montag, 23. Juli 2018, 16:13

Ich habe eine Sprog-Frage.

Hallo zusammen

-Ich habe noch keinen Sprog.
-Ich habe gestern die aktuellste JMRI-Version heruntergeladen.
-meine Decoder sind dort nicht enthalten
-Bitte keine „Warum nimmst du keine anderen Decoder“ Diskussion
-Ich möchte eine einfache Antwort auf eine Ja/Nein-Frage

Und nun die Frage
Kann man mit einem Sprog, Decoder auslesen UND programmieren, die nicht in JMRI hinterlegt sind?
Maurice